Discussion:
Problems Connecting to scanner over network
(too old to reply)
Anunay Jain
2017-07-08 15:31:31 UTC
Permalink
Raw Message
I cannot access my scanner (which is detected locally but not) over network
The ports are open and sane-ports is listening.
I have already done all the configs needed. and consulted them with several
tutorials online.
My sane client (which is on Windows ) i.e. SwingSane connects to ip but
does not detect my scanner,
While locally the scanner detect as a device.(and works)

scanimage -L
`hpaio:/usb/HP_LaserJet_M1005?serial=KJ314YS' is a Hewlett-Packard
HP_LaserJet_M1005 all-in-one device
`hpljm1005:libusb:001:006' is a Hewlett-Packard LaserJet M1005
multi-function peripheral
I have also tried multiple clients but all give same problems.

Host SANE version: scanimage (sane-backends) 1.0.24; backend version 1.0.24
Host OS: Raspbian OS 4.4.50 (Debian 8.0)
Client: Windows 10, SwingSane
James Klaas
2017-07-09 13:30:16 UTC
Permalink
Raw Message
I don't see the net backend in your scanimage output. Here's mine:

scanimage -L
device `avision:libusb:003:047' is a Hewlett-Packard ScanJet 8200 flatbed
scanner
device `net:localhost:avision:libusb:003:047' is a Hewlett-Packard ScanJet
8200 flatbed scanner

Make sure you have the networking set up correctly in saned.conf which
should just be an access list.

I have the following (names changed to protect the innocent):

127.0.0.1
localhost
192.168.1.0/24
localdomain.home.

[2002:7f00:1::]
[2002:c0a8:400::]/24

You will want to have your local IP space and maybe your local domain name.

As is mentioned elsewhere, be very conscious of your sane network access
from the internet. If you have real routed IPs for your local network be
sure to ACL them off from the rest of the world in addition to using this
list.

James
Post by Anunay Jain
I cannot access my scanner (which is detected locally but not) over network
The ports are open and sane-ports is listening.
I have already done all the configs needed. and consulted them with
several tutorials online.
My sane client (which is on Windows ) i.e. SwingSane connects to ip but
does not detect my scanner,
While locally the scanner detect as a device.(and works)
scanimage -L
`hpaio:/usb/HP_LaserJet_M1005?serial=KJ314YS' is a Hewlett-Packard
HP_LaserJet_M1005 all-in-one device
`hpljm1005:libusb:001:006' is a Hewlett-Packard LaserJet M1005
multi-function peripheral
I have also tried multiple clients but all give same problems.
Host SANE version: scanimage (sane-backends) 1.0.24; backend version 1.0.24
Host OS: Raspbian OS 4.4.50 (Debian 8.0)
Client: Windows 10, SwingSane
--
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
Loading...