Discussion:
libsane_deps.patch no longer applies
(too old to reply)
Olaf Meeuwissen
2017-06-08 13:18:59 UTC
Permalink
Raw Message
Hi,

This is just a heads up that the libsane_deps.patch that you apply
during the build of your Debian packages no longer applies.

If you try to apply it, it'll fail because I pushed a change that breaks
that patch.

Do not be alarmed ;-)

The change I pushed makes that patch unnecessary. You can safely remove
it from the list of patches you apply.

In case your interested, the change in question is

commit a2f1cc1c82e1ca4dfb04c386a6d51cfad3934d33
Author: Olaf Meeuwissen <paddy-***@member.fsf.org>
Date: 2017-06-07 22:06:05 +0900

libsane: Only depend on and link in the kitchen sink if needed

There is no need to depend on and link in all the various dependencies
for whatever backends *might* be preloaded if none are. Distributions
habitually rip these out, rightfully so, to reduce the list of package
dependencies. This will achieve the same while still doing the "right
thing" for builds that do preload one or more backens.

@binary-package-maintainers-reading-this-on-sane-devel>
If you have a similar patch, you're equally affected and should dump
that patch ;-)

Hope that helps,
--
Olaf Meeuwissen, LPIC-2 FSF Associate Member since 2004-01-27
GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13 F43E B8A4 A88A F84A 2DD9
Support Free Software https://my.fsf.org/donate
Join the Free Software Foundation https://my.fsf.org/join
--
sane-devel mailing list: sane-***@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
to sane-devel-***@lists.alioth.debian.org
Rolf Bensch
2017-06-08 20:50:35 UTC
Permalink
Raw Message
Hi Olaf,

I already patched libsane_deps.patch today. OK, now I removed
libsane_deps.patch from my ppa scripts.

Many thanks for your hint.

Cheers,
Rolf
Post by Olaf Meeuwissen
Hi,
This is just a heads up that the libsane_deps.patch that you apply
during the build of your Debian packages no longer applies.
If you try to apply it, it'll fail because I pushed a change that breaks
that patch.
Do not be alarmed ;-)
The change I pushed makes that patch unnecessary. You can safely remove
it from the list of patches you apply.
In case your interested, the change in question is
commit a2f1cc1c82e1ca4dfb04c386a6d51cfad3934d33
Date: 2017-06-07 22:06:05 +0900
libsane: Only depend on and link in the kitchen sink if needed
There is no need to depend on and link in all the various dependencies
for whatever backends *might* be preloaded if none are. Distributions
habitually rip these out, rightfully so, to reduce the list of package
dependencies. This will achieve the same while still doing the "right
thing" for builds that do preload one or more backens.
@binary-package-maintainers-reading-this-on-sane-devel>
If you have a similar patch, you're equally affected and should dump
that patch ;-)
Hope that helps,
--
Olaf Meeuwissen, LPIC-2 FSF Associate Member since 2004-01-27
GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13 F43E B8A4 A88A F84A 2DD9
Support Free Software https://my.fsf.org/donate
Join the Free Software Foundation https://my.fsf.org/join
--
sane-devel mailing list: sane-***@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
to sane-devel-***@lists.alioth.debian.org
Loading...