Discussion:
big problems between epson perfection 660 and xsane
(too old to reply)
Solliaa
2017-03-05 01:00:08 UTC
Permalink
Raw Message
hi !
since many months i have a big bug between my scanner and xsane.
in reality, since outgoing from ubuntu-mate 16.04; and again with 16.10.
= nothing runs !! :(

before that, my scanner was running fine since many many years.
needed some adaptations like here : http://srimal-techdiary.blogspot.fr/2008/04/installing-epson-perfection-660-usb.html
but all was ok.

just: it was.... now, i dont understand why nor whats happen :(
all whats was, is not more :(
i searched many and many hours on internet and the best {simplest, clearest for me} i found, are here : (sorry for the french ;) )
https://doc.ubuntu-fr.org/sane-backends
https://doc.ubuntu-fr.org/scanner_usb_non_reconnu

even if my scanner seems to be recognize =
$ sane-find-scanner -q  gives back :
found USB scanner (vendor=0x04b8 [EPSON], product=0x0114 [EPSON Scanner]) at libusb:005:002
$ scanimage -L   makes the scanner in light but nothing more.

i send you too the pages  *.conf from ' /etc/sane.d ' , if it could help you.
if more are needed > ask me.

what have you to explain to me to help for this problem, please ?

i dont have money to buy a new scanner -_- only for that.......
then, i wish very hard, its a solution for this.

thanks for your answer as soon as possible :)

sincerely yours
elis
--
--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--
Et si on changeait la rÚgle du jeu une bonne fois pour toutes?!! 
Olaf Meeuwissen
2017-03-05 11:33:05 UTC
Permalink
Raw Message
Hi Solliaa,
Post by Solliaa
hi !
since many months i have a big bug between my scanner and xsane.
in reality, since outgoing from ubuntu-mate 16.04; and again with 16.10.
= nothing runs !! :(
Hmm, I just helped someone out whose Epson 210 scanner stopped working
when he upgrade from Ubuntu 14.04 to Ubuntu 16.04 ...
Post by Solliaa
before that, my scanner was running fine since many many years.
needed some adaptations like here : http://srimal-techdiary.blogspot.fr/2008/04/installing-epson-perfection-660-usb.html
but all was ok.
OK, your scanner should be supported by the snapscan backend (and none
of the epson* backends) provided you install a copy of the firmware
somewhere. You may try commenting out one or the other entry in your
snapscan.conf. I don't know if it supports multiple files (haven't
checked the source code).
Post by Solliaa
just: it was.... now, i dont understand why nor whats happen :(
all whats was, is not more :(
i searched many and many hours on internet and the best {simplest, clearest for me} i found, are here : (sorry for the french ;) )
https://doc.ubuntu-fr.org/sane-backends
https://doc.ubuntu-fr.org/scanner_usb_non_reconnu
# Haven't had any French since fourth grade secondary school, but the
# code snippets tell a lot.

Did you install the packages from Rolf's PPA? As per

https://doc.ubuntu-fr.org/sane-backends#via_un_ppa
Post by Solliaa
even if my scanner seems to be recognize =
found USB scanner (vendor=0x04b8 [EPSON], product=0x0114 [EPSON Scanner]) at libusb:005:002
Never mind that, it doesn't mean much anymore these days.
Post by Solliaa
$ scanimage -L makes the scanner in light but nothing more.
What happens when you run this via `sudo`? As in

sudo scanimage -L

If that shows your scanner, then what about

sudo scanimage -T
Post by Solliaa
i send you too the pages *.conf from ' /etc/sane.d ' , if it could help you.
if more are needed > ask me.
what have you to explain to me to help for this problem, please ?
i dont have money to buy a new scanner -_- only for that.......
then, i wish very hard, its a solution for this.
thanks for your answer as soon as possible :)
sincerely yours
elis
Hope this helps,
--
Olaf Meeuwissen, LPIC-2 FSF Associate Member since 2004-01-27
GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13 F43E B8A4 A88A F84A 2DD9
Support Free Software https://my.fsf.org/donate
Join the Free Software Foundation https://my.fsf.org/join
--
sane-devel mailing list: sane-***@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
to sane-devel-***@lists.alioth.debian.org
Loading...