Discussion:
Canon CanoScan 9000F hangs with openSUSE Leap 42.2
(too old to reply)
Peter Kirchgessner
2017-01-11 21:17:07 UTC
Permalink
Raw Message
Hello,

I just changed to openSUSE Leap 42.2, where my Canon CanoScan 9000F
stopped working properly. scanimage scanned one page. Then stopped
working when starting to scan the next page. Scanner needed to be
switched off and on for the next scan.
Leap 42.2 comes with sane-backends V 1.0.24. After update to 1.0.25 it
works properly. The V 1.0.25 for Leap 42.2 can be installed from the
repository
http://download.opensuse.org/repositories/graphics/openSUSE_Leap_42.2/

Thanks to Andrea (1) who gave me that hint in a German forum.

sane-backend V 1.0.25 (which has a workaround for USB3-problems in the
kernel) seems also to be required for newer kernels. I tried openSUSE
Leap 42.2 with kernels 4.9.2-1-default and 4.10.0-rc3-1-vanilla.
scanimage worked for both kernels without problems for me only with
sane-backend 1.0.25.

Happy scanning
Peter
--
sane-devel mailing list: sane-***@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
to sane-devel-***@lists.alioth.debian.org
Loading...