Discussion:
Canon CanoScan LiDE 120
(too old to reply)
Andy Goss
2017-12-27 07:59:39 UTC
Permalink
Raw Message
openSUSE LEAP 42.3 - scanner not detected.

Following advice on the openSUSE forum I have built sane version 1.0.27 via

git clone git://git.debian.org/sane/sane-backends.git

But:

Although http://www.sane-project.org/sane-mfgs.html#Z-CANON shows

CanoScan LiDE 120 USB 0x04a9/0x190e Complete GL124+ based,
resolution from 75 to 2400 dpi genesys (1.0-63) sane-genesys

and http://www.sane-project.org/sane-backends.html#S-GENESYS shows

CanoScan LiDE 120 USB 0x04a9/0x190e Complete GL124+ based,
resolution from 75 to 2400 dpi

file:///usr/share/doc/packages/sane-backends/sane-mfgs.html#Z-CANON does not
include the LiDE 120

sudo sane-find-scanner
found USB scanner (vendor=0x04a9 [Canon], product=0x190e [CanoScan],
chip=GL848+) at libusb:002:003

which mentions a different chip

sudo scanimage -L finds only my MS webcam.

I Set up a "scanner" group, as advised in various places.

Created 82-canon_lide120.rules -

# Canon LiDE 120
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="190e", ENV{libsane_matched}="yes",
GROUP="scanner", MODE="0666"

VueScan now detects the scanner but the image generated is blank. 190e does a
pass of the document but the green light is not on.

/usr/local/etc/sane.d/genesys.conf contains:

# Canon LiDE 120
usb 0x04a9 0x190e

Installed: sane-backends 1.0.24-6.22

xsane recognises sane version 1.0.27 but not the scanner, just the MS webcam.

I am out of my depth here. Can I sort this out myself or do I wait for sane to
catch up with its own documentation?

Andy Goss
--
sane-devel mailing list: sane-***@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
to sane-devel-***@lists.alioth.debian.org
Loading...