Discussion:
Canon TS8050 not working correctly
Add Reply
Rolf Bensch
2017-08-02 17:27:16 UTC
Reply
Permalink
Raw Message
Hi Martin,

You can use wireshark with usb extensions:
https://wiki.wireshark.org/CaptureSetup/USB . You don't need to install
Windows in a VM.

Please provide a complete Windows USB scan session as compressed file
(e.g. zip or 7z) and a new linux logfile created with
SANE_DEBUG_PIXMA=21 xsane &> pixma.log.

Hope this helps.

Cheers,
Rolf
Hi,
I installed my new Canon TS8050 on Ubuntu 16.4 LTS with the PPA
ppa:rolfbensch/sane-git
The scanner is connected by USB. It is correctly detected. The command
SANE_DEBUG_BJNP=4 scanimage -L 2>log
detects the scanner as well.
The command scanimage -T passes all tests.
A first pre-scan with XSane works, but afterward the scanner does not
respond any more. The display says “scanning”.
A scan without a pre-scan results in the same error.
Simple Scan produces this same error on the first scan.
SANE_DEBUG_PIXMA=11 xsane &> pixma.log
shows
pixma is compiled with pthread support.
[pixma] pixma version 0.17.42
[pixma] pixma_collect_devices() found Canon PIXMA TS8000 Series at
libusb:001:005
[pixma] pixma_find_scanners() found 1 devices
[pixma] pixma_collect_devices() found Canon PIXMA TS8000 Series at
libusb:001:005
[pixma] pixma_open(): Canon PIXMA TS8000 Series
[pixma] *mp150_open***** This is a generation 5 scanner. *****
[pixma] INTR T=5.782 len=32
[pixma] 00000000:00 00 00 01 00 00 00 00 00 00 00 00 00 00 00 00
[pixma] 00000010:00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
[pixma]
[pixma] WARNING:send_time() disabled!
...
[pixma] pixma_scan(): start
[pixma] line_size=3828 image_size=6714312 channels=3 depth=8
[pixma] dpi=150x150 offset=(0,0) dimension=1276x1754
[pixma] gamma_table=0x56123178b848 source=0
[pixma] threshold=127 threshold_curve=0
[pixma] adf-wait=0
[pixma] ADF page count: 0
[pixma] OUT T=24.435 len=288
...
<?xml version="1.0" encoding="utf-8" ?><cmd
xmlns:ivec="http://www.canon.com/ns/cmd/2008/07/common/"><ivec:contents><ivec:operation>StartJob</ivec:operation><ivec:param_set
servicetype="scan"><ivec:jobID>00000001</ivec:jobID><ivec:bidi>1</ivec:bidi></ivec:param_set></ivec:contents></cmd>
<?xml version="1.0" encoding="utf-8" ?>
<cmd xmlns:ivec="http://www.canon.com/ns/cmd/2008/07/common/">
<ivec:contents>
<ivec:operation>StartJobResponse</ivec:operation>
<ivec:param_set servicetype="scan">
<ivec:response>NG</ivec:response>
<ivec:response_detail>PCScanning</ivec:response_detail>
<ivec:jobID/>
</ivec:param_set>
</ivec:contents>
</cmd>
[pixma] pixma_scan() failed EPROTO
[pixma] Reader task terminated: EPROTO
[pixma] Setting non-blocking mode
[pixma] read_image():reader task closed the pipe:0 bytes received,
6714312 bytes expected
[pixma] pixma_close(): Canon PIXMA TS8000 Series
If it helps I could analyze the communication in a Windows-system. Do
you know a good and safe analyzer? I had used USB-lyzer some years ago
and can’t use the new version any more without buying it.
Any help is appreciated
Martin
--
sane-devel mailing list: sane-***@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
Unsubscribe: Send mail with subject "unsubscribe your_password"
Loading...