Discussion:
Mustek A3 1200S detected but not working
(too old to reply)
Francisco Javier Martínez Palmer
2017-11-29 17:45:46 UTC
Permalink
Hello,

First congratulations for the software, I have been using it for several
years and never got a problem. After several years I had to buy a new
scanner for my work and I got a problem with it. I have been told that you
can help me, let me explain:


I have been using mint for some time already and I massively happy with it.
Currently I am using Mint 18.2 Cinnamon 64b (kernel 4.10.0-40).

Recently I bought a new scanner, the Mustek A3 1200S. Before buying I
checked xsane and seems that this particular scanner is not supported, but
in the mustek website offer drivers for linux (*.deb and *.rpm):
http://www.mustek.com.tw/support/driver ... product=A3 1200S&serial_no=D2I

I thought I could deal with them and get the scanner up and running but I
was wrong. I followed their instructions (for ubuntu):
Installation Steps:
(1) Superuser Login run the following command
~$ sudo su
(2) Download sane-backends_1.0.4-1_amd64.deb
(3) Command
# apt-get update
# apt-get install libusb-dev
# apt-get install libjpeg-dev
# apt-get install xsane
# apt-get remove sane-backends
# dpkg --force-overwrite -i sane-backends_1.0.4-1_amd64.deb
(4) Open Xsane UI
# xsane

The result of this process is that when I open xsane from the command line,
the scanner seems to be detected. See below the output of xsane:
Spicall: 0x055f 0x0506?
This matches what I see when I run "sane-find-scanner":
found USB scanner (vendor=0x055f, product=0x0506, chip=GL848+?) at
libusb:002:005

So far so good, xsane opens but this is the last of the good news.
I cannot scan anything, the scanner doesnt move at all. If I try to preview
I get a black page but the scanner never started scanning.

I thought that getting the very latest of sane would help, then I added the
PPA rolfbensch/sane-git, but still no success for me.

I have another pc with windows 7 and connected to it the scanner works
fine, so I know there must be some issue with those drivers or something
else I don't know.

Help please!
Thanks in advance.

PS. For your information, this email is basically a copy of the request I
posted in the linuxmint forums here:
https://forums.linuxmint.com/viewtopic.php?f=51&t=258277

Loading...